Instalando o módulo de segurança do Banco do Brasil ( Warsaw )


Aqui quem vos escreve novamente é o Bruno Gonçalves, desta vez para compartilhar um caso inusitado, a instalação do módulo de segurança para acessar o Banco do Brasil sem necessidade do plugin do Java no Linux, assim tornando compatível também com o Chrome e provavelmente diversos outros navegadores, além do Firefox que é utilizado a anos em conjunto com o plugin do Java.

O pacote .deb disponibilizado no site do BB não é compatível com o Debian e seus derivados, apenas com o Ubuntu e seus derivados, porém isso não tem nenhum sentido, na verdade o instalador que baixamos no site do BB é um instalador de outro instalador, o que para mim não faz o mínimo sentido, apenas dificulta o processo e cria dependências inexistentes.

Analisando o instalador do instalador disponibilizado pelo Debian é fácil perceber no arquivo /usr/bin/hda_bb está a referência para baixar o pacote warsaw que é o verdadeiro módulo de segurança, então se você está com problemas para instalar o módulo de segurança do BB, como foi o meu caso, a solução é simples, baixar e instalar o pacote referente à sua distribuição:

Debian, Ubuntu e derivados em versão 32 bits: https://cloud.gastecnologia.com.br/bb/downloads/ws/warsaw_setup.deb
Debian, Ubuntu e derivados em versão 64 bitshttps://cloud.gastecnologia.com.br/bb/downloads/ws/warsaw_setup64.deb


Fedora, Suse e outros .rpm de 32 bits
: https://cloud.gastecnologia.com.br/bb/downloads/ws/warsaw_setup.rpm

Fedora, Suse e outros .rpm de 64 bits: https://cloud.gastecnologia.com.br/bb/downloads/ws/warsaw_setup64.rpm

  • Em muitos casos a instalação só funciona realmente se os navegadores estiverem fechados.

Além do site do próprio banco você pode testar nesse endereço, perceba quantos bancos utilizam o mesmo sistema de segurança: http://www.dieboldnixdorf.com.br/warsaw

  • Este é o mesmo módulo usado no Banco Itaú. Quando eu acessei o Banco Itaú (pelo Linux Mint) ele perguntou se eu queria instalar o módulo.
    Após a instalação constatei que era este mesmo “Warsaw”.
    Vale uma importante ressalta…no Windows ele também pede para “instalar” o módulo, mas no windows ele tem dificuldade de reconhecer este módulo nos navegadores.
    No Linux Mint (onde testei) uma vez instalado ele NUNCA apresentou o problema, acessando o site do Banco praticamente todos os dias durante uns 6 meses…

    • Bruno Gonçalves

      O módulo funciona bem mesmo, o problema é que o BB inventou de adicionar outro instalador e não o feito pelos desenvolvedores do Warsaw, esse instalador do BB não funciona direito.

      • kravmaga

        Por acaso ontem estava tentando resolver esse problema com o BB no Ubuntu e coloquei um tutorial passo a passo do que fiz em

        http://ubuntuforum-br.org/index.php?topic=121558.msg667917

        Acho que complementa bem esse artigo, especialmente por dar o caminho passo a passo, bom para quem tem pouco domínio do linux ainda.

        • Bacana o tutorial, mas não é bem mais simples instalar apenas um pacote? 😉
          O que o BB fez foi a coisa mais bizarra e sem noção do mundo, ainda não sei porque fizeram isso.

    • Os módulos do Itaú, Caixa e BB são os mesmos, o que muda der ser a chave de verificação com o banco.

  • André Aguiar

    Muito obrigado! Estava há vários dias tentando instalar esse módulo de segurança no Ubuntu e não dava certo.

  • Aendel Evangelista

    Muito Obrigado. Estava com problemas pra instalar no meu Elementary OS e agora deu certo. 🙂

  • Katsu Abe

    Muito obrigado.
    Estava cogitando fazer uma maquina virtual apenas para acesso aos bancos, já que instalar esses módulos no Windows causa um impacto considerável na performance.
    Agora que sei que funciona na distro que quero usar, e já fica mais simples.

    • Bones Jones

      +1

    • Eu tava fazendo exatamente isso hahah

  • lucas coutinho

    eu acesso apenas usando o java da oracle, nunca foi necessário usar outro plugin.

    • Bruno Gonçalves

      Esse plugin do java será descontinuado em breve.

      • lucas coutinho

        Verdade, havia me esquecido disso.

        vou criar um ebuild para o portage.

      • Solut

        Existe o OpenJDK/IcedTea para substituí-lo, funciona bem com o Banco do Brasil e é uma solução bem melhor do que o Warsaw.

        • Bruno Gonçalves

          Openjdk também não será mais suportado pelo firefox.

  • Pingback: Como fazer funcionar os sites de banco no Linux | Monolito Nimbus()

  • Paulo Estrela

    Eu não instalaria isso na minha máquina. Somente em uma VM.

    • É complicado mesmo, não sabemos o que tem esse arquivo.
      Eu tenho uma outra solução que é usar a versão do android no PC.

      • Paulo Estrela

        É.. o problema é que no PC dá pra fazer mais coisas.

  • Orlando Madorl

    Muito obrigado mesmo e é logico compartilhando… sem copiar e colar kkkk

  • Pingback: Como instalar o módulo de segurança do Banco do Brasil no Linux()

  • Dorival Magalhaes

    Obrigado Tales, via link do Edivaldo, esta direcionando vosso site, legal, obrigado, abc…

  • Carlos Santos

    Bruno Parabéns!!! Depois de quase 3 horas tentando instalei e desinstalei o java. A sua rápida e simples dica resolveu o problema.

    Detalhe mesmo usando Ubuntu 16.04 não estava funcionando.

  • Wagner Saback Dantas

    Olá, Bruno, obrigado pela dica, funcionou aqui!

    Uso o Ubuntu 14.04 LTS em plataforma 64 bits, a única ressalva que tive para instalar o .deb do Warsaw foi instalar antes o pacote “libnss3-tools”:

    apt-get install libnss3-tools

    Fiz tudo isso com o navegador fechado. Ao abri-lo, acessei a página Web do BB e pronto.

    Cordialmente,
    Wagner Dantas.

  • Flaviofcjr

    Depois de instalar o warsaw.setup64.deb, apareceu a seguinte informação:
    WS00001

    Problemas no Módulo de Segurança W01

    Não foi possível carregar ou você não possui instalado o Módulo de Segurança.
    Efetue a limeza de cache antes da instalação:
    Nos navegadores Chrome, Firefox ou IE, utilize (Ctrl+Shift+Del).
    No navegador Safari siga os seguintes passos:
    – Clicar no Menu Safari – Preferências – Aba Privacidade
    – Clicar na opção “Remover todos dados dos sites”
    – Confirmar clicando no botão “Remover agora”
    Acesse a Página de Diagnóstico seg.bb.com.br para instalar o Módulo de Segurança.
    Após a instalação, reinicie o computador.
    Tire suas dúvidas sobre o Módulo de Segurança em https://seg.bb.com.br/duvidas.html

    Ajuda?

    • Qual distribuição instalou?
      O módulo é proprietário, foi apenas disponibilizado o arquivo para instalação do mesmo, chegou a ver isso com o bb?

      • Flaviofcjr

        Distro: Ubuntu 16.04 LTS
        Quando peço para fazer o diagnóstico, aparece um X vermelho no Socket. Peço para instalar e ele diz que não pode instalar. Pede para eu reinstalar, mas já instalei o warsaw manualmente.

        • Baixa o pacote de novo, pode ter corrompido.

          • pollux_master .

            Tá nada, velho. Aqui no meu PC (ubuntu 16.04 x64) também tá do mesmo jeito. Já baixei umas 10 vezes. É treta com o warsaw mesmo, não detecta nem com o diagnóstico, apesar de o processo estar ativo. Estive em contato com o suporte da empresa responsável e aparentemente está dando problemas com vários usuários. No meu micro do trabalho (ubuntu 14.04 x32) até detecta, mas não finaliza as configurações do banco (“Problemas no Módulo de Segurança W03”). Uma gambiarra pra fazer funcionar até 31/03 é usar a versão 51 do Firefox com o plugin Java. Depois disso, é esperar pela bondade de consertarem esse BENDITO módulo. []’s

          • Realmente, é complicado essa porcaria que os bancos criaram, eu nem uso isso, uso banco só no celular ou tablet.

          • Flaviofcjr

            Exatamente, Pollux!

            Já tentei de todo o jeito e não funciona. Mas beleza, por enquanto, tenho o app no cel ainda funcionando!
            Mesmo assim, VALEUUU, Tales!

  • Henrique alves

    Modo de instalação no Debian.

    apt-get install libnss3-tools
    sudo dpkg -i warsaw_setup64.deb